Brackets

Brackets

This year MK is 5 years old. So he decides to learnsome arithmetic. But he was confused by how towrite the brackets. He has already known that the brackets should match whenwriting them correctly. Such as “()(())” is correct but “())(” is not.

Theproblem is that, if there are N pairs of brackets, how many ways that MK can writethem correctly?           

 

Input

   There areseveral test cases. Each case contains a number N (1 <= N <= 1000)indicating the pairs of brackets.

 

Output

For each case,please output the answer mod 1,000,000,007.

Sample Input

5

7

Sample Output

42

429


大神说这个是裸的卡特兰数的题,经过大神提醒知道卡特兰数,自己查了下。

分享个有关卡特兰数的连接 http://buptdtt.blog.51cto.com/2369962/832586

知道卡特兰数这题就好做了,直接公式计算就出来了。


还有个麻烦点的地方就是mod 1,000,000,007。需要边计算边mod。


#include<iostream>
using namespace std;
long long f[1003];
int main()
{
    int n;
    f[0] = 1;
    for(int i = 1; i <= 1000; i++)
    {
        for(int j = 0; j < i; j++)
        {
            f[i] += f[j] * f[i - j - 1] % 1000000007;
            f[i] %= 1000000007;
        }
    }
    while(cin>>n) cout<<f[n]<<endl;
return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值