HDU - 6098 Inversion (2017 Multi-University Training Contest - Team 6)

Inversion


Problem Description
Give an array A, the index starts from 1.
Now we want to know  Bi=maxijAj  ,  i2 .
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integer n : the size of array A.
Next one line contains n integers, separated by space, ith number is  Ai .

Limits
T20
2n100000
1Ai1000000000
n700000
 

Output
For each test case output one line contains n-1 integers, separated by space, ith number is  Bi+1 .
 

Sample Input
  
  
2 4 1 2 3 4 4 1 4 2 3
 

Sample Output
  
  
3 4 3 2 4 4
 


题意:字面意思,那个奇怪的符号是不整除的意思


解题思路:竟然暴力搜索就过了……当时还不敢相信,不敢写……先排序再爆搜。



#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include <string.h>
#include <math.h>
#include <vector>
#include <set>
#include <map>
#include <queue>
#include <stack>
#define mem(a,b) memset(a,b,sizeof(a))

using namespace std;

int t,n;
const int MAX_N=1e5+7;
struct node
{
    int ind,val;
} a[MAX_N];
bool cmp(node x,node y)
{
    if(x.val==y.val)
    return x.ind<y.ind;
    return x.val>y.val;
}
int main()
{

    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i].val);
            a[i].ind=i;
        }
        sort(a+1,a+n+1,cmp);
        for(int i=2;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(a[j].ind%i!=0)
                {
                    if(i!=n)
                    {
                        printf("%d ",a[j].val);
                        break;
                    }
                    else
                    {
                        printf("%d\n",a[j].val);
                        break;
                    }
                }
            }
        }
    }
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值