POJ - 3797 Tiling a Grid With Dominoes(递推)

Tiling a Grid With Dominoes

Description

We wish to tile a grid 4 units high and N units long with rectangles (dominoes) 2 units by one unit (in either orientation). For example, the figure shows the five different ways that a grid 4 units high and 2 units wide may be tiled. 



Write a program that takes as input the width, W, of the grid and outputs the number of different ways to tile a 4-by-W grid.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow. 

Each dataset contains a single decimal integer, the width, W, of the grid for this problem instance.

Output

For each problem instance, there is one line of output: The problem instance number as a decimal integer (start counting at one), a single space and the number of tilings of a 4-by-W grid. The values of W will be chosen so the count will fit in a 32-bit integer.

Sample Input

3 
2 
3 
7

Sample Output

1 5 
2 11 
3 781

Source





题意:给你无数个1*2的方块,问你拼出4*N长度的矩形有多少种拼法。


解题思路:递推即可,详细看图片和代码。这道题其实是用来练习状压DP的,但是不会写……以后学了插头DP再回来看看。




          图0


     

                


         图  1                                                                                图2





#include<iostream>
#include<deque>
#include<memory.h>
#include<stdio.h>
#include<map>
#include<string>
#include<algorithm>
#include<vector>
#include<math.h>
#include<stack>
#include<queue>
#include<set>
#define INF 1<<29
using namespace std;

//图0
int dp[1005];
int a[1005];
int b[1005];
int c[1005];

int main()
{
    dp[0]=1;dp[1]=1;
    a[0]=0;a[1]=1;
    b[0]=1;b[1]=1;
    c[0]=1;c[1]=1;

    for(int i=2;i<1005;i++){
        dp[i]=a[i-1]+b[i-1]+c[i-1]+dp[i-1]+dp[i-2];//图1
        a[i]=a[i-2]+dp[i-1];//图2

        b[i]=c[i-1]+dp[i-1];//自己思考
        c[i]=b[i-1]+dp[i-1];//自己思考
    }

    int t;
    scanf("%d",&t);
    for(int qqq=1;qqq<=t;qqq++){
        int w;
        scanf("%d",&w);
        printf("%d %d\n",qqq,dp[w]);

    }

    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值