POJ - 1947 Rebuilding Roads(树上背包)

Rebuilding Roads

Description

The cows have reconstructed Farmer John's farm, with its N barns (1 <= N <= 150, number 1..N) after the terrible earthquake last May. The cows didn't have time to rebuild any extra roads, so now there is exactly one way to get from any given barn to any other barn. Thus, the farm transportation system can be represented as a tree. 

Farmer John wants to know how much damage another earthquake could do. He wants to know the minimum number of roads whose destruction would isolate a subtree of exactly P (1 <= P <= N) barns from the rest of the barns.

Input

* Line 1: Two integers, N and P 

* Lines 2..N: N-1 lines, each with two integers I and J. Node I is node J's parent in the tree of roads. 

Output

A single line containing the integer that is the minimum number of roads that need to be destroyed for a subtree of P nodes to be isolated. 

Sample Input

11 6
1 2
1 3
1 4
1 5
2 6
2 7
2 8
4 9
4 10
4 11

Sample Output

2

Hint

[A subtree with nodes (1, 2, 3, 6, 7, 8) will become isolated if roads 1-4 and 1-5 are destroyed.] 


题意:给你一棵树,问你要形成一个大小为P的子树,最少要剪多少条边。


解题思路:树形DP入门题。用到了背包的思想,重点在于枚举所有子树并枚举所有的P的情况。方程详见代码。




#include<iostream>
#include<deque>
#include<memory.h>
#include<stdio.h>
#include<map>
#include<string.h>
#include<algorithm>
#include<vector>
#include<math.h>
#include<stack>
#include<queue>
#include<set>
using namespace std;
typedef long long int ll;

int dp[200][200];//以i为根节点的子树,只保留j个点,所需要减去的最少边
int fa[200];//记录父亲,用于找根节点
vector<int> childs[200];
int n,p;


void dfs(int v,int fa){
    //如果是根节点,只保留1个节点的话,肯定是把所有孩子减去即可。如果不是根节点,那么就要多剪一个父亲。
    dp[v][1]=childs[v].size()-(v!=fa);
    
    for(int i=0;i<childs[v].size();i++){
        int ch=childs[v][i];
        if(ch==fa)
            continue;
        dfs(ch,v);//从上往下遍历

        //背包问题模板
        for(int j=p;j>0;j--)
            for(int s=1;s<j;s++)
                //前者为使用这个子树,后者为不使用这个子树。使用子树的话要枚举使用这个子树多少个点的情况。
                dp[v][j]=min(dp[v][j-s]+dp[ch][s]-1,dp[v][j]);
    }
}


int main()
{

    while(~scanf("%d%d",&n,&p)){

        memset(dp,0x3f3f3f3f,sizeof(dp));
        memset(fa,-1,sizeof(fa));

        int a,b;
        for(int i=2;i<=n;i++){
            scanf("%d%d",&a,&b);
            childs[a].push_back(b);
            childs[b].push_back(a);
            fa[b]=a;
        }

        int i=1;
        while(fa[i]!=-1)
            i=fa[i];

        dfs(i,i);

        int ans=dp[i][p];//根节点不用减父亲
        for(int j=1;j<=n;j++)
            ans=min(ans,dp[j][p]+1);//要把父亲剪掉

        printf("%d\n",ans);

        for(int i=0;i<=n;i++)
            childs[i].clear();
    }

    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值