C - A^X mod P

Description

It's easy for ACMer to calculate A^X mod P. Now given seven integers n, A, K, a, b, m, P, and a function f(x) which defined as following.

f(x) = K, x = 1

f(x) = (a*f(x-1) + b)%m , x > 1


Now, Your task is to calculate

( A^(f(1)) + A^(f(2)) + A^(f(3)) + ...... + A^(f(n)) ) modular P. 

Input

  In the first line there is an integer T (1 < T <= 40), which indicates the number of test cases, and then T test cases follow. A test case contains seven integers n, A, K, a, b, m, P in one line.

1 <= n <= 10^6

0 <= A, K, a, b <= 10^9

1 <= m, P <= 10^9

Output

  For each case, the output format is “Case #c: ans”. 

c is the case number start from 1.

ans is the answer of this problem.

Sample Input

2
3 2 1 1 1 100 100
3 15 123 2 3 1000 107

Sample Output

Case #1: 14
Case #2: 63

思路:
f(x)分解成f(x)=q*x+j;所以A^f(x)=(A^x)^q*A^j;
即将f(x)的值分段存,即A^f(x)分段存(将A^f(x)分为每段长为33333的33333段,求A^f(x)时先求在哪一段里面,再求这一段里面具体哪个位置。

#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
#define maxn 33333
long long x[2*maxn],y[2*maxn];
long long n,A,K,a,b,m,p;
void init()
{
    x[0]=1;
    for(int i=1;i<=maxn;i++){
        x[i]=(x[i-1]*A)%p;
    }
    long long temp=x[maxn];
    y[0]=1;
    for(int i=1;i<=maxn;i++){
        y[i]=(y[i-1]*temp)%p;
    }
}
void solve(int tx)
{
    long long fx=K;
    long long ans=0;
    for(int i=1;i<=n;i++){
        ans=(ans+(y[fx/maxn]*x[fx%maxn])%p)%p;
        fx=(a*fx+b)%m;
    }
    cout<<"Case #"<<tx<<": "<<ans<<endl;
}
int main ()
{
    int t;
    cin>>t;
    for(int l=1;l<=t;l++){
        cin>>n>>A>>K>>a>>b>>m>>p;
        init();
        solve(l);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值