ap = a (mod p)

B - B
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes
如果理解题意就很简单了。。
题解:先判断p是不是质数,如果是输出no然后判断a的p次方对p取模是否等于a
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
#include<stdio.h>
#include<math.h>
int s(long long a)
{
	if(a==2)
	return 1;
	for(int i=2;i*i<=a;i++)
	if(a%i==0)
	return 0;
	return 1;
}
long long f(long long a,long long b,long long c)//快速幂模板
{
	long long t=1%c;
	a=a%c;
	while(b>0)
	{
		if(b%2==1)
		t=t*a%c;
		b=b/2;
		a=a*a%c;
	}
	return t;
}
int main()
{
__int64 a,p;
	while(~scanf("%I64d%I64d",&p,&a)&&!(a==0&&p==0))
	{
		if(s(p))
		printf("no\n");
		else
		{
			if(f(a,p,p)==a)
    	    printf("yes\n");
	       else
	       printf("no\n");	
		}
	
	}
	return 0;
}

 
   
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值