Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5Sample Output
2 4
import java.util.Scanner;
public class Main {
static int[] pre=new int[3005];
public static void main(String[] args) {
// TODO Auto-generated method stub
int n;
Scanner scanner=new Scanner(System.in);
n=scanner.nextInt();
while(true) {
if(n<=0)break;
int x,y;
x=scanner.nextInt();
y=scanner.nextInt();
int[] v = new int[1005];
for(int i = 1 ; i <= x ; i++ )
{
pre[i] = i;
}
for( int i = 0 ; i < y ; i++ )
{
int a=scanner.nextInt();
int b=scanner.nextInt();
Main.judge(a, b);
}
for( int i = 1 ; i <= x ; i++)
{
Main.find(i);
v[pre[i]]=1;
}
int num=0;
for(int i = 1 ; i <= x ; i++) {
if(v[i]==1)num++;
}
System.out.println(num);
n--;
}
}
public static int find(int x) {
int r=x;
while(pre[r]!=r) {//查找前导节点
r=pre[r];
}
int i=x,j;
while(i!=r)//压缩路径(修改前导节点)
{
j=pre[i];
pre[i]=r;
i=j;
}
return r;
}
public static void judge(int a, int b) {
int x=Main.find(a);
int y=Main.find(b);
if(x!=y) {
pre[x]=y;
}
}
}