数字格式异常

编写一个程序,提示用户读取两个整数,然后显示他们的和。程序应该在输入不正确时提示用户再次输入数字

输入样例:

i 9
l 8
5 6

输出样例:

Incorrect input and re-enter two integers:
Incorrect input and re-enter two integers:
Sum is 11

import java.util.InputMismatchException;
import java.util.Scanner;

public class Exception{
	public static void main(String[] args) {
		Scanner in=new Scanner(System.in);
		while(in.hasNext()){
			try{
				int m=in.nextInt();
				int n=in.nextInt();
				System.out.println("Sum is "+(m+n));
			}
			catch(InputMismatchException e){
				System.out.println("Incorrect input and re-enter two integers:");
				//Scanner对象发生异常后就不能再被使用,所以一直报异常,一直输出上面的语句,编程出现死循环
				in.nextLine();  //必须重置Scanner对象解决死循环
			}
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值