hdu 6129 (杨三角技巧)

Just do it

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 1415    Accepted Submission(s): 826


Problem Description
There is a nonnegative integer sequence a1...n of length n . HazelFan wants to do a type of transformation called prefix-XOR, which means a1...n changes into b1...n , where bi equals to the XOR value of a1,...,ai . He will repeat it for m times, please tell him the final sequence.
 

Input
The first line contains a positive integer T(1T5) , denoting the number of test cases.
For each test case:
The first line contains two positive integers n,m(1n2×105,1m109) .
The second line contains n nonnegative integers a1...n(0ai2301) .
 

Output
For each test case:
A single line contains n nonnegative integers, denoting the final sequence.
 

Sample Input
  
  
2 1 1 1 3 3 1 2 3
 

Sample Output
  
  
1 1 3 1
解:列出某个序列异或3次 就能发现其系数满足杨辉三角,这样我们就能够知道 异或m次时他们的所有系数,如图:
上代码:
#include <iostream>
#include <string.h>
using namespace std;
typedef long long ll;
const int maxn=2e5+10;
ll a[maxn];
ll b[maxn];
int main()
{
	  int t,n,m;
	  cin>>t;
	  while (t--)
	  {
	  	 memset(b,0,sizeof(b));
	  	 scanf("%d%d",&n,&m);
	  	 for (int i=1;i<=n;i++)
	  	 scanf("%lld",&a[i]);
	  	 int y=m-1;
	  	 for (int i=1;i<=n;i++)
	  	 {
			   int x=m+i-2;
			   if ((x&y)==y)
			   {
			   	   for (int j=i;j<=n;j++)
			   	   b[j]=b[j]^a[j-i+1];
			   }	
		 }
		 for (int i=1;i<=n;i++)
		 if (i==1)
		 printf("%lld",b[i]);
		 else
		 printf(" %lld",b[i]);
		 printf("\n");
	  }
	  return 0;
} 

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值