HDU5015~Number Sequence(位运算)

Number Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2516    Accepted Submission(s): 1010
Special Judge


Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● a i ∈ [0,n] 
● a i ≠ a j( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a 0 ⊕ b 0) + (a 1 ⊕ b 1) +···+ (a n ⊕ b n)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line contains an integer n(1 ≤ n ≤ 10 5), The second line contains a 0,a 1,a 2,...,a n.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b 0,b 1,b 2,...,b n. There is exactly one space between b i and b i+1 (0 ≤ i ≤ n - 1). Don’t ouput any spaces after b n.
 

Sample Input
  
  
4 2 0 1 4 3
 

Sample Output
  
  
20 1 0 2 3 4
 

Source
 

Recommend
hujie
 

Statistic |  Submit |  Discuss |  Note

题意:n+1个数的序列,每个数不重复,都在0~n范围内,求最大的t,公式题中已给出,就是保证每个a[i]^b[i]最大,a[i]^b[i]最大,也就是转换成二进制,每一位都不同,则对每一个a[i]都有一个唯一的b[i]使得a[i]^b[i]最大,暴力,每次把1往左移一位,移后判断一下&a[i]==0,如果=0,则加上,以此求出最大。
#include<stdio.h>
#include<string.h>
#include<math.h>
typedef  long long ll;
using namespace std;
ll a[100005];
ll b[100005];
int main()
{
   ll n;
   while(~scanf("%lld",&n))
   {
       memset(b,-1,sizeof(b));
       for(int i=0;i<=n;i++)
        scanf("%lld",&a[i]);
        ll ans=0,p;
       for(int i=n;i>=0;i--)
       {
           p=0;
           if(b[i]==-1)
           {
               for(int j=0;(1<<j)<i;j++)
                  if((i&(1<<j))==0)
                    p+=(1<<j);
               b[p]=i;
               b[i]=p;
               ans+=(i^p)*2;
           }
       }
       printf("%lld\n",ans);
       for(int i=0;i<=n;i++)
       {
           if(i==0)
            printf("%lld",b[a[i]]);
           else
            printf(" %lld",b[a[i]]);
       }
       printf("\n");
   }
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值