06-图2 Saving James Bond - Easy Version (25分)

06-图2 Saving James Bond - Easy Version   (25分)

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers NN (\le 100100), the number of crocodiles, and DD, the maximum distance that James could jump. Then NN lines follow, each containing the (x, y)(x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No


用的DFS,开始没注意中间是个圆。。。。最后才发现是读题的问题。

#include<iostream>
#include<cstdlib>
#include<cmath>
using namespace std;
int n,m,flag[101];
bool f=false;
struct point
{
	int x,y;
}p[101];
typedef struct graphnode *Graph;
struct graphnode
{
	int G[101][101];
};
void Insertedge(Graph g,int x,int y)
{
	g->G[x][y]=1;
	g->G[y][x]=1;
}
Graph Create()
{
	cin>>n>>m;
	Graph g=(Graph)malloc(sizeof(struct graphnode));
	g->G[0][0]=0;
	p[0].x=0;
	p[0].y=0;
	for(int i=1;i<=n;i++)
	{
		cin>>p[i].x>>p[i].y;
		for(int j=0;j<i;j++)
		{
			if(sqrt((p[j].x-p[i].x)*(p[j].x-p[i].x)+(p[j].y-p[i].y)*(p[j].y-p[i].y)*1.0)<=m+7.5)
			{
				if(j==0)
				Insertedge(g,i,j);
				else
				if(sqrt((p[j].x-p[i].x)*(p[j].x-p[i].x)+(p[j].y-p[i].y)*(p[j].y-p[i].y)*1.0)<=m)
				Insertedge(g,i,j);
			}
		}
	}
	return g;
}
void dfs(Graph g,int x)
{
	if((50-abs(p[x].x))<=m||(50-abs(p[x].y))<=m)
	{
		f=true;
		return;
	}
	if(f)
	{
		return;
	}
	for(int i=0;i<101;i++)
	{
		if(g->G[x][i]==1&&!flag[i])
		{
			flag[x]=1;
			dfs(g,i);
			flag[x]=0;
		}
	}
}
int main()
{
	Graph g=Create();
	flag[0]=1;
	dfs(g,0);
	if(f)
	{
		cout<<"Yes"<<endl;
	}
	else
	{
		cout<<"No"<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

没想好叫什么名字

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值