C - Parenthesis

Bobo has a balanced parenthesis sequence P=p 1 p 2…p n of length n and q questions.
The i-th question is whether P remains balanced after p ai and p bi  swapped. Note that questions are individual so that they have no affect on others.
Parenthesis sequence S is balanced if and only if:
1. S is empty;
2. or there exists balanced parenthesis sequence A,B such that S=AB;
3. or there exists balanced parenthesis sequence S' such that S=(S').
Input
The input contains at most 30 sets. For each set:
The first line contains two integers n,q (2≤n≤10 5,1≤q≤10 5).
The second line contains n characters p 1 p 2…p n.
The i-th of the last q lines contains 2 integers a i,b i (1≤a i,b i≤n,a i≠b i).

Output
For each question, output " Yes" if P remains balanced, or " No" otherwise.
Sample Input
4 2
(())
1 3
2 3
2 1
()
1 2
Sample Output
No
Yes
No
 
 
暴力的话,优化一下可以过,在这里给的时间很长,但是有个比较巧妙的方法。
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
	long n,q;
	while(cin>>n>>q)
	{
		char a[100005];
		int b[100005],c[100005];
		b[0]=0,c[0]=0;
		for(int i=1;i<=n;i++)
		{
			cin>>a[i];
			if(a[i]=='(')
				b[i]=b[i-1]+1;
			else
				b[i]=b[i-1]-1;
			if(b[i]<=1)
				c[i]=c[i-1]+1;
			else
				c[i]=c[i-1];
		}
		while(q--)
		{
			long x1,y1,x,y;
			cin>>x1>>y1;
			x=min(x1,y1);
			y=max(x1,y1);
			if(n==0)
			{
				cout<<"Yes"<<endl;
				continue;
			}
			if(a[x]==a[y])
			{
				cout<<"Yes"<<endl;
				continue;
			}
			else
				if(a[x]=='(')
				{
					if(c[y-1]-c[x-1]>0)
						cout<<"No"<<endl;
					else
						cout<<"Yes"<<endl;
				} 
				else
					cout<<"Yes"<<endl;
		}
	}
	return 0;
}


 
 
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

没想好叫什么名字

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值