5-18 Hashing - Hard Version

5-18 Hashing - Hard Version   (30分)

Given a hash table of size NN, we can define a hash function . Suppose that the linear probing is used to solve collisions, we can easily obtain the status of the hash table with a given sequence of input numbers.

However, now you are asked to solve the reversed problem: reconstruct the input sequence from the given status of the hash table. Whenever there are multiple choices, the smallest number is always taken.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer NN (\le 10001000), which is the size of the hash table. The next line contains NN integers, separated by a space. A negative integer represents an empty cell in the hash table. It is guaranteed that all the non-negative integers are distinct in the table.

Output Specification:

For each test case, print a line that contains the input sequence, with the numbers separated by a space. Notice that there must be no extra space at the end of each line.

Sample Input:

11
33 1 13 12 34 38 27 22 32 -1 21

Sample Output:

1 13 12 21 33 34 38 27 22 32


拓扑排序+哈希表

#include<iostream>
#include<vector>
#include<queue>
using namespace std;
struct node
{
	int x,y;
	node(int a,int b):x(a),y(b){}
};
int main()
{
	int n;
	cin>>n;
	int *Hash=new int[n];
	int *Degree=new int[n];
	vector<vector<int> > G(n);
	vector<int>ans;
	for(int i=0;i<n;i++)
	{
		cin>>Hash[i];
		if(Hash[i]>=0)
			Degree[i]=0;
		else
			Degree[i]=-1;
	}
	for(int i=0;i<n;i++)
	{
		if(Hash[i]<0)
			continue;
		int now=i;
		int hashcode=Hash[i]%n;
		Degree[i]=(now-hashcode+n)%n;
		for(int s=0;s<Degree[i];s++)
		{
			G[(hashcode+s+n)%n].push_back(i);
		}
	}
	priority_queue<pair<int,int>,vector<pair<int,int> >,greater<pair<int,int> > >Q;
	for(int i=0;i<n;i++)
	{
		if(Degree[i]==0)
		{
			Q.push(pair<int,int>(Hash[i],i));
		}
	}
	while(!Q.empty())
	{
		pair<int,int> p=Q.top();
		int V=p.second;
		ans.push_back(p.first);
		Q.pop();
		for(int i=0;i<G[V].size();i++)
			if(--Degree[G[V][i]]==0)
				Q.push(pair<int,int>(Hash[G[V][i]],G[V][i]));
	}
	cout<<ans[0];
	for(int i=1;i<ans.size();i++)
		cout<<" "<<ans[i];
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

没想好叫什么名字

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值