7-18 Hashing - Hard Version (30 分)(哈希表,拓扑排序)

Given a hash table of size N, we can define a hash function H(x)=x%N. Suppose that the linear probing is used to solve collisions, we can easily obtain the status of the hash table with a given sequence of input numbers.

However, now you are asked to solve the reversed problem: reconstruct the input sequence from the given status of the hash table. Whenever there are multiple choices, the smallest number is always taken.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), which is the size of the hash table. The next line contains N integers, separated by a space. A negative integer represents an empty cell in the hash table. It is guaranteed that all the non-negative integers are distinct in the table.

Output Specification:

For each test case, print a line that contains the input sequence, with the numbers separated by a space. Notice that there must be no extra space at the end of each line.

Sample Input:

11

33 1 13 12 34 38 27 22 32 -1 21

Sample Output:

1 13 12 21 33 34 38 27 22 32

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <vector>
#include <stack>
#include <queue>
#include <cmath>
using namespace std;
const int maxn=1010;
const int inf=999999;
vector<int> indegree;
bool visit[maxn];
int e[maxn][maxn];
int a[maxn];
int count[maxn];
int n,cnt;
void topSort(){     //拓扑排序
    queue<int> q;
    for(int i=0;i<n;i++){
        int u=-1,min=inf;
        for(int j=0;j<n;j++){
            if(visit[j]==false&&!indegree[j])
                if(a[j]<min){       //每次都选取最小的入队(其实用数组输出也一样)
                    min=a[j];
                    u=j;
                }
        }
        if(u==-1) break;
        visit[u]=true;
        q.push(a[u]);
        for(int v=0;v<n;v++){
            if(visit[v]==false&&e[u][v]){
                e[u][v]=0;
                indegree[v]--;
            }
        }
    }
    int flag=0;
    while(!q.empty()){      //输出
        if(q.front()!=-1){
            if(!flag){
                cout<<q.front();
                q.pop();
                flag=1;
            }else{
                cout<<" ";
                cout<<q.front();
                q.pop();
            }
        }else{
            q.pop();
        }
    }
}
int main()
{
    fill(e[0],e[0]+maxn*maxn,0);
    cin>>n;
    cnt=n;
    indegree.resize(n);
    for(int i=0;i<n;i++){
        cin>>a[i];
    }
    for(int i=0;i<n;i++){
        if(a[i]==-1) continue;
        int index=a[i]%n;
        if(index!=i){
            indegree[i]=(i-index+n)%n;  //计算入度
            for(int j=0;j<indegree[i];j++)
                e[(index+j)%n][i]=1;   //计算连通的边
        }
    }
    topSort();
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小火汁猛猛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值