the input type of the launch configuration

使用junit进行单元测试的时候提示:

the input type of the launch configuration


本人使用的测试方法是在项目下新建folder,用于测试,直接右键test folder,build path, use as resource folder done


博主设置当前文章不允许评论。

MyEclipse8:No server is associated with this launch configuration

01-12

这个问题已经困扰我3个月了,目前还是没有解决,问题如下:rn环境:rnmyeclipse8.0GA、weblogic8.1、框架s2sh.rn1、使用myeclipse8启动debug时,会抛出如下错误:rn[code=Java]rnjava.lang.NullPointerExceptionrnat com.genuitec.eclipse.easie.core.AppServerRegistry.registerServer(Unknown Source)rnat com.genuitec.eclipse.easie.core.AppServerRegistry.refreshLaunchConfigServer(Unknown Source)rnat com.genuitec.eclipse.easie.core.EASIECore$1.launchConfigurationChanged(Unknown Source)rnat org.eclipse.debug.internal.core.LaunchManager$ConfigurationNotifier.run(LaunchManager.java:218)rnat org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)rnat org.eclipse.debug.internal.core.LaunchManager$ConfigurationNotifier.notify(LaunchManager.java:199)rnat org.eclipse.debug.internal.core.LaunchManager.launchConfigurationChanged(LaunchManager.java:2098)rnat org.eclipse.debug.internal.core.LaunchConfigurationWorkingCopy.writeNewFile(LaunchConfigurationWorkingCopy.java:323)rnat org.eclipse.debug.internal.core.LaunchConfigurationWorkingCopy.doSave0(LaunchConfigurationWorkingCopy.java:248)rnat org.eclipse.debug.internal.core.LaunchConfigurationWorkingCopy.doSave(LaunchConfigurationWorkingCopy.java:219)rnat org.eclipse.debug.internal.core.LaunchConfigurationWorkingCopy.doSave(LaunchConfigurationWorkingCopy.java:173)rnat org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer.handleApplyPressed(LaunchConfigurationTabGroupViewer.java:1366)rnat org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer$3.widgetSelected(LaunchConfigurationTabGroupViewer.java:366)rnat org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:228)rnat org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)rnat org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)rnat org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3880)rnat org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3473)rnat org.eclipse.jface.window.Window.runEventLoop(Window.java:825)rnat org.eclipse.jface.window.Window.open(Window.java:801)rnat org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationsDialog.open(LaunchConfigurationsDialog.java:1064)rnat org.eclipse.debug.ui.DebugUITools$1.run(DebugUITools.java:398)rnat org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)rnat org.eclipse.debug.ui.DebugUITools.openLaunchConfigurationDialogOnGroup(DebugUITools.java:406)rnat org.eclipse.debug.ui.DebugUITools.openLaunchConfigurationDialogOnGroup(DebugUITools.java:340)rnat org.eclipse.debug.ui.actions.OpenLaunchDialogAction.run(OpenLaunchDialogAction.java:81)rnat org.eclipse.jface.action.Action.runWithEvent(Action.java:498)rnat org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)rnat org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)rnat org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:411)rnat org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)rnat org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)rnat org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3880)rnat org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3473)rnat org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2405)rnat org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)rnat org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)rnat org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)rnat org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)rnat org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:493)rnat org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)rnat org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:113)rnat org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)rnat org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)rnat org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)rnat org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)rnat org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)rnat sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)rnat sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)rnat sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)rnat java.lang.reflect.Method.invoke(Method.java:597)rnat org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)rnat org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)rnat org.eclipse.equinox.launcher.Main.run(Main.java:1311)rnrnrn[/code]rnrn2、在run选项中配置完domain后,点击“launch"-->"create launch configuration" 后台会抛如下错误:rn[code=Java]rn/*rneclipse.buildId=unknownrnjava.version=1.6.0_13rnjava.vendor=Sun Microsystems Inc.rnBootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=zh_CNrnCommand-line arguments: -os win32 -ws win32 -arch x86rnrnrnrnTue Jan 12 20:24:43 CST 2010rnrn*/rnrnjava.lang.NullPointerExceptionrn at com.genuitec.eclipse.easie.core.AppServerRegistry.registerServer(Unknown Source)rn at com.genuitec.eclipse.easie.core.AppServerRegistry.refreshLaunchConfigServer(Unknown Source)rn at com.genuitec.eclipse.easie.core.EASIECore$1.launchConfigurationAdded(Unknown Source)rn at org.eclipse.debug.internal.core.LaunchManager$ConfigurationNotifier.run(LaunchManager.java:212)rn at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)rn at org.eclipse.debug.internal.core.LaunchManager$ConfigurationNotifier.notify(LaunchManager.java:199)rn at org.eclipse.debug.internal.core.LaunchManager.launchConfigurationAdded(LaunchManager.java:2071)rn ....rnrnrnrn[/code]rnrn3、另外,在配置好debug的时候,界面会弹出:rnrnNo server is associated with this launch configuration. This is likely caused by attempting to launch the server before workbench startup completes. Please wait until MyEclipse finishes loading and try again.rnrn本机已经配置正确JDK/JRE。rnrn4、本地配置tomcat/jboss均正常,只有WebLogic8.1出此问题。实在找不到办法了,请大虾们帮忙解决。谢谢。rnrn

没有更多推荐了,返回首页

私密
私密原因:
请选择设置私密原因
  • 广告
  • 抄袭
  • 版权
  • 政治
  • 色情
  • 无意义
  • 其他
其他原因:
120
出错啦
系统繁忙,请稍后再试

关闭