zufeoj_因式分解

题目链接:http://acm.ocrosoft.com/problem.php?cid=1222&pid=29


题目描述

1 < n < = 2^31 
n = a1*a2*a3*a4.......*am 
比如: 
12=12 
12=6*2 
12=4*3 
12=3*4 
12=3*2*2 
12=2*6 
12=2*3*2 
12=2*2*3 

总共8种


输入

输出

样例输入

12

样例输出

8

#include<bits/stdc++.h>
using namespace std;
int n;
int a[11111];
int ans=0;
int cnt=0;
void dfs(int mul){
    if(mul==n){
        ans++;
        return;
    }
    for(int i=1;i<cnt;i++){
        if(mul*a[i]>n){
            break;
        }
        //剪枝  否则会超时 
        if(n%(mul*a[i])==0){
            dfs(mul*a[i]);
        }
    }
}
int main(){
    while(cin>>n){
        cnt=0;
        ans=0;
        for(int i=1;i<=sqrt(n);i++){
            if(n%i==0){
                a[cnt]=i;
                cnt++;
                if(i!=n/i){
                    a[cnt]=n/i;
                    cnt++;
                }
            }
        }
        sort(a,a+cnt);
        dfs(1);
        cout<<ans<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值