zzuli oj 因式分解

题目链接

题目描述

给定N个数,求出这N个数所有可能积的和

输入

第一行输入T(T<=10),第二行输入N(1<=N<=1e6)  ,第三行输入N个数(1<=ai<=1e9)

输出

输出它们所有可能积的和,答案数据过大,请对1e9+7取模。

样例输入 Copy

3
2
3 4
3
1 2 3
5
1 2 3 4 5

样例输出 Copy

19
23
719

提示

可以随意选择两个数相乘,也可以选择N个数相乘(包含选择一个数的情况) 
case1:3+4+3*4=19 
case2:1+2+3+2+3+6+6=23 

 

用手算一下,题目已经提示是因式分解

答案就是 (a1+1)*(a2+1)*(a3+1)*......*(an+1)-1

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string.h>
#include<queue>
#include<stack>
#include<list>
#include<map>
#include<set>
#include<vector>
using namespace std;
typedef long long int ll;
typedef unsigned long long ull;
const int maxn =1e6+5;
const int maxm=10000;
const int mod =1e9+7;
const int INF=0x3f3f3f3f;
const double eps=1e-8;
const int MAXN=1000010;
 
int main()
{
    int t;scanf("%d",&t);
    while(t--)
    {
        ll ans=1;
        int n;scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            int x;scanf("%d",&x);
            ans=ans*(x+1)%mod;
        }
        printf("%lld\n",ans-1);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值