PAT (Advanced Level) Practice — 1002 A+B for Polynomials (25 分)

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805526272000000

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

polynomials 多项式     exponents指数      coefficients系数

:题意 两个多项式相加,相同指数的部分将系数相加,最后把结果按指数的从大到小进行排序(项数、指数、系数)

:思路 double型数组a的下标 i 记录指数,a[i]记录系数,并将数组初始化,将输入的数据指数相同的部分相加,从1001-0遍历,若数组里的值不为0,则说明系数存在(非零),项数cnt++,按题目要求逆序打印多项式的每一系数非零项

最后不要忘记保留一位小数!!!

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int main(){
	int n,m;
	int x;
	double xi; 
	double a[1111];
	memset(a,0,sizeof(a));
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>x>>xi;
		a[x]+=xi;
	}
	cin>>m; 
	for(int i=0;i<m;i++){
		cin>>x>>xi;
		a[x]+=xi;
	}
	int cnt=0;
	for(int i=0;i<1001;i++){
		if(a[i]!=0){
			cnt++;
		}
	}
	cout<<cnt;
	for(int i=1001;i>=0;i--){
		if(a[i]!=0){
			printf(" %d %.1lf",i,a[i]);
		}
	}
	cout<<endl;
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值