red and black(hdu-1241)

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21854    Accepted Submission(s): 13306


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

Source
 

题目大意:一个人站在“@”,他可以往四个方向走,“.”可以走,“#”不可以走,问全图他一共可以走多少个点?

代码如下:

import java.util.*;
public class Main 
{
	public static Scanner in = new Scanner(System.in);
	public static int hang,lie,startx,starty;
	public static char[][] map = new char[101][101];
	public static void main(String[] args) 
	{
		while(inint())
		check();
	}       
	public static void check()
	{
		bfs(startx,starty);
		int answer = 0;
		for(int i=0 ; i<hang ; i++)
		{
			for(int j=0 ; j<lie ; j++)
			{
				if(map[i][j]=='@')
					answer++;
			}
		}
		System.out.println(answer);
	}
	public static void bfs(int x,int y)
	{
		map[x][y] = '@';
		int x_go[] = {0,0,-1,1};
		int y_go[] = {1,-1,0,0};
		for(int i=0 ; i<4 ; i++)
		{
			int temx = x + x_go[i];
			int temy = y + y_go[i];
			if(temx<0 || temx==hang)continue;
			if(temy<0 || temy==lie)continue;
			if(map[temx][temy] == '#')continue;
			if(map[temx][temy] == '@')continue;
			bfs(temx,temy);
		}
	}
	public static boolean inint()
	{
		lie = in.nextInt();
		hang = in.nextInt();
		if(hang+lie==0)return false;
		String str;
		for(int i=0 ; i<hang ; i++)
		{
			str = in.next();
			for(int j=0 ; j<lie ; j++)
			{
				map[i][j] = str.charAt(j);
				if(map[i][j]=='@')
				{
					startx = i;
					starty = j;
				}
			}
		}
		return true;
	}
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值