Red and Black HDU - 1312

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13

题目大意:就是从@出发能踩到多少个‘.’,遇到#不能走;

思路:明显是一道dfs,dfs又是递归,所以要有递归边界。。。。

下面是ac代码:(感觉这个写法不是很标准,所以还是用下面那种写法)

#include<cstdio>
#include<string.h>
#include<algorithm>
using namespace std;
int mp[25][25],vis[25][25],ans,n,m;
int go[][2]={0,1,0,-1,1,0,-1,0};
void dfs(int x,int y)
{
            for(int k=0;k<4;k++)
            {
                int xx=x+go[k][0];
                int yy=y+go[k][1];
                if(xx>=n||xx<0||yy>=m||yy<0||vis[xx][yy]==1||mp[xx][yy]=='#')
                    continue;
                vis[xx][yy]=1;
                ans++;
                dfs(xx,yy);
            }
}
int main()
{
    while(scanf("%d%d",&m,&n)==2&&n&&m)
    {
        memset(vis,0,sizeof(vis));
        ans=0;
        getchar();
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
                scanf("%c",&mp[i][j]);
                getchar();
        }
        int flat=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(mp[i][j]=='@')
                {
                    ans++;
                    vis[i][j]=1;
                    dfs(i,j);
                    flat=1;
                    break;
                }

            }if(flat)
                    break;
        }
        printf("%d\n",ans);
    }
    return 0;
}
ac2:

#include<cstdio>
#include<string.h>
#include<algorithm>
using namespace std;
int mp[25][25],vis[25][25],ans,n,m;
int go[][2]={0,1,0,-1,1,0,-1,0};
void dfs(int x,int y)
{
        if(x<0||x>=n||y<0||y>=m||vis[x][y]==1||mp[x][y]=='#')
            return;
            ans++;
            vis[x][y]=1;
        for(int i=0;i<4;i++)
        {
            int xx=x+go[i][0];
            int yy=y+go[i][1];
            dfs(xx,yy);
        }
}
int main()
{
    while(scanf("%d%d",&m,&n)==2&&n&&m)
    {
        memset(vis,0,sizeof(vis));
        ans=0;
        getchar();
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
                scanf("%c",&mp[i][j]);
                getchar();
        }
        int flat=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(mp[i][j]=='@')
                {

                    dfs(i,j);
                    flat=1;
                    break;
                }

            }if(flat)
                    break;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值