PAT (Advanced Level) Practice A1084 Broken Keyboard (20 分)(C++)(甲级)(散列)

1084 Broken Keyboard (20 分)
On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es
Sample Output:

7TI

//B1029 旧键盘 (20 分)英文版
//https://blog.csdn.net/m0_37454852/article/details/86476172

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

int Key[50] = {0};

int mapping(char ch)//查询该字符的散列位置
{
    if(ch>='a' && ch<='z') return ch-'a';//A~Z在0~25
    else if(ch>='A' && ch<='Z') return ch-'A';
    else if(ch>='0' && ch<='9') return ch-'0' + 26;//0~9在26~35
    return 36;//_在36
}

int main()
{
    char str1[100] = {0}, str2[100] = {0};
    scanf("%s", str1);
    int len1 = strlen(str1);
    int x=0;
    for(int i=0; i<len1; i++)
    {
        x = mapping(str1[i]);
        if(!Key[x]) Key[x] = 1;//在第一个字符中出现,把标志置为1
    }
    scanf("%s", str2);
    int len2 = strlen(str2);
    for(int i=0; i<len2; i++)
    {
        x = mapping(str2[i]);//在第二串字符中出现把标志清零
        Key[x] = 0;
    }
    for(int i=0; i<len1; i++)//再次扫描第一个字符串,若标志为1,说明该按键坏掉了
    {
        x = mapping(str1[i]);
        if(Key[x])
        {
            if(x<26) printf("%c", 'A'+x);
            else if(x<36) printf("%c", '0'+x-26);
            else printf("_");
            Key[x] = 0;//之后记得清零,否则可能会多次输出
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值