PAT-A1084/B1029 Broken Keyboard/旧键盘 题目内容及题解

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及实际被输入的文字,请你列出肯定坏掉的那些键。

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

输入在 2 行中分别给出应该输入的文字、以及实际被输入的文字。每段文字是不超过 80 个字符的串,由字母 A-Z(包括大、小写)、数字 0-9、以及下划线 _(代表空格)组成。题目保证 2 个字符串均非空。

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI

解题思路

  1. 读入两个字符串;
  2. 建立与字符串对应的哈希表;
  3. 对两个字符串进行遍历,遍历过程中遇到一致的两个指针均后移一位,如果遇上不一致的则将第一个字符串指针所指内容查哈希表,如未遇到过则哈希置1,并将其加入结果字符串,如果遇到过则跳过,指针前进一位;
  4. 直到第一个字符串的指针到达结尾;
  5. 输出结果并返回零值。

代码

#include<stdio.h>

#define maxn 128

int HashTable[maxn];
char res[maxn];

int main(){
    char s1[maxn],s2[maxn];
    int num=0;
    int i=0,j=0;
    scanf("%s%s",&s1,&s2);
    while(s1[i]!=0){
        if(s1[i]==s2[j]){
            i++;
            j++;
        }else{
            if(s1[i]>='a'&&s1[i]<='z'){
                if(HashTable[s1[i]]==0){
                    res[num++]=s1[i]-32;
                    HashTable[s1[i]]=1;
                    HashTable[s1[i]-32]=1;
                }
            }else if(s1[i]>='A'&&s1[i]<='Z'){
                if(HashTable[s1[i]]==0){
                    res[num++]=s1[i];
                    HashTable[s1[i]]=1;
                    HashTable[s1[i]+32]=1;
                }
            }else if(s1[i]>='0'&&s1[i]<='9'){
                if(HashTable[s1[i]]==0){
                    res[num++]=s1[i];
                    HashTable[s1[i]]=1;
                }
            }else if(s1[i]=='_'){
                if(HashTable[s1[i]]==0){
                    res[num++]=s1[i];
                    HashTable[s1[i]]=1;
                }
            }
            i++;
        }
    }
    printf("%s\n",res);
    return 0;
}

运行结果

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值