PAT (Advanced Level) Practice A1041 Be Unique (20 分)(C++)(甲级)(散列)

1041 Be Unique (20 分)
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​ ]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17
Sample Output 1:

31
Sample Input 2:

5 888 666 666 888 888
Sample Output 2:

None


using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

int num[10010] = {0};//每个数字出现的次数
int bet[100010] = {0};//每个人赌出的数字

int main()
{
    int N = 0;
    scanf("%d", &N);
    for(int i=0; i<N; i++)
    {
        scanf("%d", &bet[i]);
        num[bet[i]]++;//该数字出现次数累计
    }
    int flag = 0;//已经出现则置一,没有满足题意的则输出None
    for(int i=0; i<N; i++)
    {
        if(num[bet[i]] == 1)//首次赌出的唯一数字
        {
            flag = 1;
            printf("%d", bet[i]);
            break;
        }
    }
    if(!flag) printf("None");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值