PAT (Advanced Level) Practice 1041

1041 Be Unique (20)(20 point(s))

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 10^4^]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=10^5^) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None
题意:输入n(n<=10^5)个正整数,找出第一个不重复的数即可。
思路:因为只要求找倒第一个不重复的数,并且每一个数都是10000以内的,所以只需要把每一个数保存起来,并以key的形式保存到map中。第二次遍历时,只要有一个数为1,那么肯定是答案。复杂度O(n)
代码:
#include<cstdio>
#include<map>
using namespace std;
map<int, int>mmap;
int main(){
	int n;
	scanf("%d", &n);
	int arr[10010];
	for(int i = 0;i < n;i++){
		scanf("%d", &arr[i]);
		mmap[arr[i]]++;
	}
	for(int i = 0;i < n;i++){
		if(mmap[arr[i]] == 1){
			printf("%d", arr[i]);
			return 0;
		}
	}
	printf("None");
	return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值