PAT (Advanced Level) Practice A1049 Counting Ones (30 分)(C++)(甲级)

1049 Counting Ones (30 分)
The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (≤2 ​30).

Output Specification:

For each test case, print the number of 1’s in one line.

Sample Input:

12
Sample Output:

5

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

int pow(int x, int y)//求幂
{
    if(!y) return 1;
    return x*pow(x, y-1);
}

int main()
{
    int S[50] = {0};
    int N, cnt = 0, top = -1, temp_cnt = 1;
    scanf("%d", &N);
    int M = N;//把N复制
    while(N)//把N拆分
    {
        S[++top] = N%10;
        N /= 10;
    }
    N = M;//重新赋给N
    for(int i=0; i<=top; i++)
    {
        if(!S[i]) cnt += N/10 * pow(10, i);//该位为0,则存在N/10 * 10^i个1
        else if(S[i] == 1) cnt += N/10 * pow(10, i) + M%pow(10, i) + 1;//该位为1,则还需要考虑其后面的那部分
        else cnt += (N/10+1) * pow(10, i);//该位大于1,则(N/10+1) * 10^i个1
        N /= 10;
    }
    printf("%d", cnt);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值