PAT (Advanced Level) Practise 1049 Counting Ones (30)

174 篇文章 0 订阅
100 篇文章 0 订阅

1049. Counting Ones (30)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (<=230).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:
12
Sample Output:
5

题意:给你一个n,问1~n中一共出现了几个1

解题思路:可以发现0~9出现了1个1,0~99出现了10+1*10个1,0~999出现了100+20*10个1......然后可以根据这个规律去打表,之后就可以根据这个表去进行模拟


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

LL a[16],n,x[16];

void init()
{
    a[0]=0,a[1]=1;
    LL x=10;
    for(int i=2;i<16;i++) a[i]=x+a[i-1]*10,x*=10;
}

int main()
{
    init();
    while(~scanf("%lld",&n))
    {
        int cnt=0;
        LL ans=0,m=n,k=1;
        while(n) {x[cnt++]=n%10,n/=10,k*=10;}
        k/=10;
        for(int i=cnt-1;i>=0;i--)
        {
            ans+=a[i]*x[i];
            if(x[i]==1) ans+=(m-k*x[i]+1);
            if(x[i]>1) ans+=k;
            m-=(k*x[i]);
            k/=10;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值