Cube Stacking

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 
Input
* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 
Output
Print the output from each of the count operations in the same order as the input file. 
Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
Sample Output
1
0
2

分析:

deep[i]表示编号为i的cube距离top的cube深度是多少

num[i]表示编号为i的cube有几个孩子结点,i本身也算。

每次join(a,b)的时候,就把a及以上的点deep算好了

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=30002;
int num[maxn],deep[maxn],pre[maxn];

int f(int a){
    if(pre[a]==a)return a;
    int tmp=pre[a];
    pre[a]=f(tmp);
    deep[a]+=deep[tmp];
    return pre[a];
}

void join(int a,int b){
    int root1=f(a),root2=f(b);
    if(root1!=root2){
        pre[root2]=root1;
        deep[root2]=num[root1];
        num[root1]+=num[root2];
    }
}

int main(){
    for(int i=1;i<=maxn;i++){
        pre[i]=i;
        num[i]=1;
        deep[i]=0;
    }
    int p,a,b,x;
    char ch[5];
    scanf("%d",&p);
    while(p--){
        scanf("%s",&ch);
        if(ch[0]=='M'){
            scanf("%d%d",&a,&b);
            join(a,b);
        }
        else {
            scanf("%d",&x);
            f(x);
            printf("%d\n",num[f(x)]-deep[x]-1);
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值