L2-006 树的遍历 (25 分)
给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
思路:
后序,中序推前序:
1、后序遍历的最后一个点是根节点,然后在中序遍历中找到根节点所在的位置,找到后,根节点左边的就是左子树,右边的就是右子树。
2、并从左右两个子树开始向下递归,循环第1条。
层序遍历:
1、用到了队列,先把根节点入队
2、再队列不为空的情况下,出队,把出队的节点对应的左右节点入队。
3、循环第2步
代码如下:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<queue>
#include<stack>
#include<cmath>
#include<set>
#include<map>
using namespace std;
#define ll long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef pair<int,int>P;
const int INF=0x3f3f3f3f;
const int N=35,N1=5005,mod=32767;
int a[N],b[N];
struct node{
struct node *lc,*rc;
int elem;
};
int n;
node *solve(int *after,int *in,int len){
if(len==0)return NULL;
node *q=new node;
int k=0;
for(;k<len;k++){
if(in[k]==*(after+len-1))break;
}
q->elem=*(after+len-1);
q->lc=solve(after,in,k);
q->rc=solve(after+k,in+k+1,len-k-1);
return q;
}
void FloorPrint(node *q){
queue<node*>qqq;
int k=0;
qqq.push(q);
while(!qqq.empty()){
node *tmp=qqq.front();qqq.pop();
k++;
if(k==1)printf("%d",tmp->elem);
else if(k==n)printf(" %d\n",tmp->elem);
else printf(" %d",tmp->elem);
if(tmp->lc){
qqq.push(tmp->lc);
}
if(tmp->rc){
qqq.push(tmp->rc);
}
}
}
int main(){
scanf("%d",&n);
for(int i=0;i<n;i++){
scanf("%d",&a[i]);
}
for(int i=0;i<n;i++){
scanf("%d",&b[i]);
}
node *q=solve(a,b,n);
FloorPrint(q);
}
L2-011 玩转二叉树
给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N
(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
7
1 2 3 4 5 6 7
4 1 3 2 6 5 7
输出样例:
4 6 1 7 5 3 2
思路:反转二叉树,输出其层序遍历的时候只需要先入队右子树,后入队左子树
代码如下:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<queue>
#include<stack>
#include<cmath>
#include<set>
#include<map>
using namespace std;
#define ll long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef pair<int,int>P;
const int INF=0x3f3f3f3f;
const int N=35,N1=5005,mod=32767;
int a[N],b[N];
struct node{
struct node *lc,*rc;
int elem;
};
int n;
node *solve(int *in,int *pre,int len){
if(len==0){
return NULL;
}
node *q=new node;
q->elem=*pre;
int k=0;
for(;k<len;k++){
if(in[k]==*pre)break;
}
q->lc=solve(in,pre+1,k);
q->rc=solve(in+k+1,pre+k+1,len-k-1);
return q;
}
void FloorPrint(node *q){
queue<node*>qqq;
int k=0;
qqq.push(q);
while(!qqq.empty()){
node *tmp=qqq.front();qqq.pop();
k++;
if(k==1)printf("%d",tmp->elem);
else if(k==n)printf(" %d\n",tmp->elem);
else printf(" %d",tmp->elem);
if(tmp->rc){
qqq.push(tmp->rc);
}
if(tmp->lc){
qqq.push(tmp->lc);
}
}
}
int main(){
scanf("%d",&n);
for(int i=0;i<n;i++){
scanf("%d",&a[i]);
}
for(int i=0;i<n;i++){
scanf("%d",&b[i]);
}
node *q=solve(a,b,n);
FloorPrint(q);
}