hdu1081 - 最大子矩阵(矩阵压缩)

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16399    Accepted Submission(s): 7523

Problem Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.

Input

The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4

0 -2 -7 0 9 2

-6 2 -4 1 -4 1 -1

8 0 -2

Sample Output

15

思路:

我写了个O(n^4)的AC代码……后来网上学习了一下聚聚们的代码,O(n^3),用到了矩阵压缩

对于一行求最大连续子序的时候,设个tmp=0,一直加a1,a2……

若某一个位置上加成了负数,则更新为0(最大连续子序的首末端不为负数)

反之就往后加

这个题是把以为扩展到了二维的情况

从第1行开始,每次压缩(就是求第i行到第j行对应元素的加和)

eg:

第1行和第1行压缩,在得到的n个数中找,最大连续子序

第1行和第2行压缩,在得到的n个数中找,最大连续子序

第1行和第2行和第3行压缩,在得到的n个数中找,最大连续子序

第1行和第2行和……第n行压缩,在得到的n个数中找,最大连续子序

第2行和第2行压缩

第2行和第3行压缩

……

第2行和第3行和……第n行压缩,

找出这里的最大值即可

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<queue>
#include<stack>
#include<cmath>
#include<set>
#include<map>
#include<functional>
using namespace std;
#define ll long long

typedef pair<ll,int>P;
const int INF=0x3f3f3f3f;
const int N=105,mod=1e9+7;
int a[N][N];
int sum[N][N];
int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&a[i][j]);
                sum[i][j]=sum[i-1][j]+a[i][j];
            }
        }
        int mx=-1;
        for(int i=1;i<=n;i++){//从第1行开始
            for(int j=i;j<=n;j++){
                int all=0;
                for(int k=1;k<=n;k++){
                    int t=sum[j][k]-sum[i-1][k];
                    all+=t;
                    if(all<0)all=0;
                    if(all>mx){
                        mx=all;
                    }
                }
            }
        }
        printf("%d\n",mx);
    }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值