Description
Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
Input
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
Output
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
Sample Input
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75
Sample Output
$1581.42
主要是setprecision的用法,可以控制输出的位数(并进行四舍五入),需要添加头文件 #include <iomanip>
setprecision会自动省略小数最后几位的0,如果想完全输出,可以在前面加上 fixed
#include <iostream>
#include <iomanip>
#include <algorithm>
using namespace std;
int main()
{
double s[12];
int i = 0;
double num = 0;
while (i < 12) {
cin >> s[i];
num += s[i];
i++;
}
double ave_num = num / 12;
cout << '$';
cout << setprecision(0.2) << ave_num << endl;
return 0;
}