北大oj1017——Packets

Packets

Time Limit: 1000MS Memory Limit: 10000K

Description

A factory produces products packed in square packets of the same height h and of the sizes 11, 22, 33, 44, 55, 66. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 11 to the biggest size 66. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output

2
1

原以为是啥动态规划算法实践。。。

#include<iostream>
#include<algorithm>
#include <string>
using namespace std;

int main() {
    int n[7];
    while (true)
    {
        bool isEnd = true;
        for (int i = 1; i <= 6; i++) {
            cin >> n[i];
            if (n[i] != 0) {
                isEnd = false;
            }
        }

        if (isEnd) {
            break;
        }

        //从大到小尽可能的填箱子
        int cnt = 0;
        for (int i = 6; i >= 1; i--) {
            if (i == 6 && n[6]) {
                cnt += n[6];
            }
            else if (i == 5 && n[5]) {
                cnt += n[5];
                int useOne = min(n[5] * 11, n[1]);
                n[1] -= useOne;
            }
            else if (i == 4 && n[4]) {
                cnt += n[4];
                int useTwo = min(n[4] * 5, n[2]);
                n[2] -= useTwo;
                int useOne = min((n[4] * 5 - useTwo) * 4, n[1]);
                n[1] -= useOne;
            }
            else if (i == 3 && n[3]) {
                cnt += (n[3] / 4);
                int lastThree = n[3] % 4;
                if (lastThree > 0) {
                    cnt += 1;
                }
                if (lastThree == 1) {
                    int useTwo = min(5, n[2]);
                    n[2] -= useTwo;
                    int useOne = min((5 - useTwo) * 4 + 7, n[1]);
                    n[1] -= useOne;
                }
                else if (lastThree == 2) {
                    int useTwo = min(3, n[2]);
                    n[2] -= useTwo;
                    int useOne = min((3 - useTwo) * 4 + 6, n[1]);
                    n[1] -= useOne;
                }
                else if (lastThree == 3) {
                    int useTwo = min(1, n[2]);
                    n[2] -= useTwo;
                    int useOne = min((1 - useTwo) * 4 + 5, n[1]);
                    n[1] -= useOne;
                }
            }
            else if (i == 2 && n[2]) {
                cnt += (n[2] / 9);
                int lastThree = n[2] % 9;
                if (lastThree > 0) {
                    cnt += 1;
                }
                int useOne = min((9 - lastThree) * 4, n[1]);
                n[1] -= useOne;
            }
            else if (i == 1 && n[1]) {
                cnt += (n[1] / 36);
                int lastThree = n[1] % 36;
                if (lastThree > 0) {
                    cnt += 1;
                }
            }
        }

        cout << cnt << endl;
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

椰子糖莫莫

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值