北大oj1016——Numbers That Count

Numbers That Count

Time Limit: 1000MS Memory Limit: 10000K

Description

"Kronecker's Knumbers" is a little company that manufactures plastic digits for use in signs (theater marquees, gas station price displays, and so on). The owner and sole employee, Klyde Kronecker, keeps track of how many digits of each type he has used by maintaining an inventory book. For instance, if he has just made a sign containing the telephone number "5553141", he'll write down the number "5553141" in one column of his book, and in the next column he'll list how many of each digit he used: two 1s, one 3, one 4, and three 5s. (Digits that don't get used don't appear in the inventory.) He writes the inventory in condensed form, like this: "21131435".
The other day, Klyde filled an order for the number 31123314 and was amazed to discover that the inventory of this number is the same as the number---it has three 1s, one 2, three 3s, and one 4! He calls this an example of a "self-inventorying number", and now he wants to find out which numbers are self-inventorying, or lead to a self-inventorying number through iterated application of the inventorying operation described below. You have been hired to help him in his investigations.
Given any non-negative integer n, its inventory is another integer consisting of a concatenation of integers c1 d1 c2 d2 ... ck dk , where each ci and di is an unsigned integer, every ci is positive, the di satisfy 0<=d1<d2<...<dk<=9, and, for each digit d that appears anywhere in n, d equals di for some i and d occurs exactly ci times in the decimal representation of n. For instance, to compute the inventory of 5553141 we set c1 = 2, d1 = 1, c2 = 1, d2 = 3, etc., giving 21131435. The number 1000000000000 has inventory 12011 ("twelve 0s, one 1").
An integer n is called self-inventorying if n equals its inventory. It is called self-inventorying after j steps (j>=1) if j is the smallest number such that the value of the j-th iterative application of the inventory function is self-inventorying. For instance, 21221314 is self-inventorying after 2 steps, since the inventory of 21221314 is 31321314, the inventory of 31321314 is 31123314, and 31123314 is self-inventorying.
Finally, n enters an inventory loop of length k (k>=2) if k is the smallest number such that for some integer j (j>=0), the value of the j-th iterative application of the inventory function is the same as the value of the (j + k)-th iterative application. For instance, 314213241519 enters an inventory loop of length 2, since the inventory of 314213241519 is 412223241519 and the inventory of 412223241519 is 314213241519, the original number (we have j = 0 in this case).
Write a program that will read a sequence of non-negative integers and, for each input value, state whether it is self-inventorying, self-inventorying after j steps, enters an inventory loop of length k, or has none of these properties after 15 iterative applications of the inventory function.

Input

A sequence of non-negative integers, each having at most 80 digits, followed by the terminating value -1. There are no extra leading zeros.

Output

For each non-negative input value n, output the appropriate choice from among the following messages (where n is the input value, j is a positive integer, and k is a positive integer greater than 1):
n is self-inventorying
n is self-inventorying after j steps
n enters an inventory loop of length k
n can not be classified after 15 iterations

Sample Input

22
31123314
314213241519
21221314
111222234459
-1

Sample Output

22 is self-inventorying
31123314 is self-inventorying
314213241519 enters an inventory loop of length 2
21221314 is self-inventorying after 2 steps
111222234459 enters an inventory loop of length 2

这道题倒是不难,就是不支持c++11的新特性有点难受,,,to_string用不了,又用回sprintf_s。
还有一点,,题目看了半天,,,囧囧囧

#include<iostream>
#include<algorithm>
#include <string>
using namespace std;

int _array[16][161];

int calc(int aim, int self) {
    for (int i = 0; _array[aim][i] == _array[self][i]; i++) {
        if (_array[aim][i] == -1) {
            return 1;
        }
    }
    return 0;
}

int calcHead(int index) {
    if (index <= 0) {
        return -1;
    }
    for (int i = 0; i < index; i++) {
        if (calc(i, index) == 1) {
            return i;
        }
    }
    return -1;
}

std::string ItoA(int n) {
    char ss[10];
    sprintf_s(ss, "%d", n);
    std::string s(ss);

    return s;
}

int main() {
    char s[81];
    while (true) {
        cin >> s;
        if (s[0] == '-') {
            break;
        }

        memset(_array, -1, sizeof(_array));
        for (int i = 0; s[i] != NULL; i++) {
            _array[0][i] = s[i] - '0';
        }

        bool isSuccess = false;

        for (int i = 0; i < 15; i++) {
            int n[10];
            std::string str = "";
            memset(n, 0, sizeof(n));
            for (int j = 0; _array[i][j] != -1; j++) {
                n[_array[i][j]] ++;
            }
            for (int j = 0; j <= 9; j++) {
                if (n[j] > 0) {
                    str = str + ItoA(n[j]) + ItoA(j);
                }
            }
            for (int j = 0; str[j] != NULL; j++) {
                _array[i+1][j] = str[j] - '0';
            }
            int result = calcHead(i + 1);

            if (result >= 0) {
                if (result == 0 && i + 1 == 1) {
                    cout << s << " is self-inventorying" << endl;
                }
                else {
                    if (i + 1 - result == 1) {
                        cout << s << " is self-inventorying after " << i << " steps" << endl;
                    }
                    else {
                        cout << s << " enters an inventory loop of length " << i + 1 - result << endl;
                    }
                }

                isSuccess = true;
                break;
            }
        }

        if (!isSuccess) {
            cout << s << " can not be classified after 15 iterations" << endl;
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

椰子糖莫莫

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值