[UVA](11461)Square Numbers ---完全平方数

A square number is an integer number whose square root is also an integer. For example 1, 4, 81 are some square numbers. Given two numbers a and b you will have to find out how many square numbers are there between a and b (inclusive).

 

Input

The input file contains at most 201 lines of inputs. Each line contains two integers a and b (0<a≤b≤100000). Input is terminated by a line containing two zeroes. This line should not be processed.

 

Output

For each line of input produce one line of output. This line contains an integer which denotes how many square numbers are there between a and b (inclusive).


Sample Input

1 4

1 10

0 0

Sample Output

2

3

#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
int main()
{
    int a;
    int b;
    while(scanf("%d %d",&a,&b)&& a && b)
    {
        cout<<int(sqrt(b))-int(ceil(sqrt(a)))+1<<endl;
    }
    return 0;
}
题意:给你一个区间[a,b]让你求这个区间内有多少个完全平方数

解法:观察连续平方数如:1,4,9,16,25,36,49……将他们开方后1,2,3,4,5……就会发现规律了。

注意:左端点开方后得到的小数,在保留成整数的时候,要四舍五入。例如[7,64]  sqrt(7)=2,   sqrt(64)=8  8-2+1=7 然而[7,64]之间的完全平方数有

9,16,25,36,49,64这6个 ,显然不对,所以要用到celi这个函数。


函数名: ceil
用 法: double ceil(double x);
功 能: 返回大于或者等于指定表达式的最小整数
头文件: math.h
返回数据类型:double


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值