Question:
A square number is an integer number whose square root is also an integer. For example 1, 4, 81 are
some square numbers. Given two numbers a and b you will have to find out how many square numbers
are there between a and b (inclusive).
Input
The input file contains at most 201 lines of inputs. Each line contains two integers a and b (0 < a ≤
b ≤ 100000). Input is terminated by a line containing two zeroes. This line should not be processed.
Output
For each line of input produce one line of output. This line contains an integer which denotes how
many square numbers are there between a and b (inclusive).
Sample Input
1 4
1 10
0 0
Sample Output
2
3
题意大意:如果一个数能被写成一个整数的平方,则次数未完全平方数。现在给你a,b两个数,算出[a,b]区间中的完全平方数。
(http://acm.hust.edu.cn/vjudge/contest/121559#problem/K)
思路:区间[a,b]间的完全平方数等于[0,b]间的完全平方数减去[0,a]的完全平方数(ps:如果a是完全平方数,其结果还应该在+1);
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int vis[1000005],dp[1000005];
void init()
{
memset(vis,0,sizeof(vis));
for(int i=1;i<=1000;i++)
vis[i*i]=1;
}
void init2()
{
dp[1]=1;
for(int i=2;i<=1000000;i++)
{
if(vis[i]==1)
dp[i]=dp[i-1]+1;
else
dp[i]=dp[i-1];
}
} // 将每个数对应的[0,n]之间的个数用数组保存
int main()
{
int n,m;
init();
init2();
while (1)
{
scanf("%d%d",&n,&m);
if(n==0&&m==0)
break;
if(vis[n]==1)
printf("%d\n",dp[m]-dp[n]+1);
else printf("%d\n",dp[m]-dp[n]);
}
return 0;
}
体会:将区间转化为区间相减,简化问题