Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 15398 | Accepted: 6510 |
Description
Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).
To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.
Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).
FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.
Input
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
Output
Sample Input
25 5 2 2 14 11 21 17
Sample Output
4
Hint
#include<iostream>
#include<algorithm>
#include<cstdio>
#define INF 1000000005
typedef long long LL;
using namespace std;
int L,n,m;
long long x[100005];
bool check(LL d)
{
int cnt=1;
int now=x[0];
for(int i=1;i<=n+1;i++)
{
if(x[i]-now>=d)
{
cnt++;
now=x[i];
}
if(cnt>=m)
return true;
}
return false;
}
void bSearch()
{
LL l=0;
LL r=INF;
LL mid;
while(r-l>1)
{
mid=(l+r)/2;
if(check(mid)) l=mid;
else r=mid;
}
printf("%lld\n",l);//最终满足题意时,一定是满足条件的,所以要求的d(mid)被赋给了l,那么我们输入l即可
}
int main()
{
while(scanf("%d %d %d",&L,&n,&m)!=EOF)
{
for(int i=0;i<n;i++)
scanf("%lld",&x[i+1]);
x[0]=0;
x[n+1]=L;
sort(x,x+n+2);
m=n+2-m;
bSearch();
}
return 0;
}