[HDU](5974)A Simple Math Problem ---数论

Problem Description

Given two positive integers a and b,find suitable X and Y to meet the conditions:
X+Y=a
Least Common Multiple (X, Y) =b

Input

Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.

Output

For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of “No Solution”(without quotation).

Sample Input

6 8
798 10780

Sample Output

No Solution
308 490

Source

2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)

题意:给你两个数a,b,然后找到两个数x,y 满足 x+y = a, lcm(x,y) = b 找不到的话输出No Solution

思路:一开始的想法就是暴力枚举,12W组测试数据果断TLE了。 后来知道了一个数论,即gcd(a,b) = gcd(x,y) 并且x+y和x*y互质

推理过程:

1、gcd(x,y) = g

2、x*y/gcd(x,y) = x*y/g = lcm(x,y) = b

x/g = i , y/g = j, 即i*j*g = b

3、x+y = (i+j)*g = a

4、i+j =a/g,i*j = b/g 因为i和j互质,那么i+j和i*j也互质

所以gcd(a,b) = g = gcd(x,y)

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<queue>
#include<stack>
using namespace std;
typedef long long ll;
ll gcd(ll x,ll y)
{
    if(y == 0)
        return x;
    else
        return gcd(y,x%y);
}
ll big(ll a,ll b,ll l)
{
    return a*b/l;
}
int main()
{
    ll a,b;
    while(~scanf("%lld %lld",&a,&b))
    {
        ll g = gcd(a,b);
        ll bb = a/g;
        bb = -bb;
        ll c = b/g;
        if(bb*bb>=4*c)
        {
            ll x = (ll)(-bb+sqrt(bb*bb-4*c))/2;
            ll y = -bb-x;
            ll xx = x*g;
            ll yy = y*g;
            if(xx>yy)
                swap(xx,yy);
            if(xx+yy == a && big(xx,yy,g) == b)
                printf("%lld %lld\n",xx,yy);
            else
                printf("No Solution\n");
        }
        else
            printf("No Solution\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值