HDU - 5974 A Simple Math Problem 解方程

A Simple Math Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1567    Accepted Submission(s): 434


Problem Description
Given two positive integers a and b,find suitable X and Y to meet the conditions:
                                                        X+Y=a
                                              Least Common Multiple (X, Y) =b
 

Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.
 

Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).
 

Sample Input
  
  
6 8 798 10780
 

Sample Output
  
  
No Solution 308 490
 

Source

设gcd(x,y)= k

x=i*k,y=j*k,且i,j互质

则a=(i+j)*k

b=x*y/gcd(x,y)= i*j*k

i,j互质,i+j和i*j也互质(因为i*j的因子只有i,j和1,而i+j的因子是绝对不会有i和j的,可以用反证法证明)

因此gcd(a,b)=k==gcd(x,y)

这样基本就可解了

x+y=a;

x*y=b*k;

#include<bits/stdc++.h>
using namespace std;
long long gcd(long long a,long long b)
{
	return b?gcd(b,a%b):a;
}
int main()
{
	long long a,b;
	while(~scanf("%lld %lld",&a,&b))
	{
		long long l=gcd(a,b);
		long long xx=a*a-4*b*l;
		if(xx<0)
		printf("No Solution\n");
		else
		{
			long long ans1=(long long)((a+sqrt(xx))/2);
			long long ans2=a-ans1;
			if(ans1*ans2/gcd(ans1,ans2)==b)
			printf("%lld %lld\n",ans2,ans1);
			else
			printf("No Solution\n");
		}
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值