[POJ](3614)Sunscreen ---- 优先级队列+贪心

Description

To avoid unsightly burns while tanning, each of the C (1 ≤ C ≤ 2500) cows must cover her hide with sunscreen when they’re at the beach. Cow i has a minimum and maximum SPF rating (1 ≤ minSPFi ≤ 1,000; minSPFi ≤ maxSPFi ≤ 1,000) that will work. If the SPF rating is too low, the cow suffers sunburn; if the SPF rating is too high, the cow doesn’t tan at all……..

The cows have a picnic basket with L (1 ≤ L ≤ 2500) bottles of sunscreen lotion, each bottle i with an SPF rating SPFi (1 ≤ SPFi ≤ 1,000). Lotion bottle i can cover coveri cows with lotion. A cow may lotion from only one bottle.

What is the maximum number of cows that can protect themselves while tanning given the available lotions?

Input

  • Line 1: Two space-separated integers: C and L
  • Lines 2..C+1: Line i describes cow i’s lotion requires with two integers: minSPFi and maxSPFi
  • Lines C+2..C+L+1: Line i+C+1 describes a sunscreen lotion bottle i with space-separated integers: SPFi and coveri

Output

A single line with an integer that is the maximum number of cows that can be protected while tanning

Sample Input

3 2
3 10
2 5
1 5
6 2
4 1

Sample Output

2

新知:
学习使用优先级队列
参考:
http://www.hankcs.com/program/cpp/poj-3614-sunscreen.html

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#include<functional>
using namespace std;
const int MAX = 2505;
typedef struct Cow
{
    int l;
    int h;
}node1;
node1 cow[MAX];
typedef struct SPF
{
    int p;
    int num;
}node2;
node2 spf[MAX];
bool cmp1(node1 a,node1 b)
{
    return a.l<b.l;
}
bool cmp2(node2 a,node2 b)
{
    return a.p<b.p;
}
int main()
{
    priority_queue<int,vector<int>,greater<int> >qi;//值越小的数据优先级越高
    ios_base::sync_with_stdio(false);
    cin.tie(NULL),cout.tie(NULL);
    int C,L;
    cin>>C>>L;
    for(int i=0;i<C;i++)
        cin>>cow[i].l>>cow[i].h;
    for(int i=0;i<L;i++)
        cin>>spf[i].p>>spf[i].num;
    sort(cow,cow+C,cmp1);
    sort(spf,spf+L,cmp2);
    int now = 0;
    int ans = 0;
    for(int i=0;i<L;i++)
    {
        while(now<C && cow[now].l<=spf[i].p)
        {
            qi.push(cow[now].h);
            now++;
        }
        while(spf[i].num && !qi.empty())
        {
            int t = qi.top();
            qi.pop();
            if(t>=spf[i].p)
            {
                ans++;
                spf[i].num--;
            }
        }
    }
    cout<<ans<<endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值