算出一组字符串里出现最对的一组

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result. 

This year, they decide to leave this lovely job to you. 
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters. 

A test case with N = 0 terminates the input and this test case is not to be processed. 
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case. 
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink
 
 
#include<stdio.h>
#include<string.h>
int main()
{
        int n;
        int i,j=0;
        char store[1000][20];//储存字符串,未初始化即为0
        char t[20];
        int max;
        int count[1000]={0};//用来计第几个字符串出现的次数,并且用0初始化只能进行一次
        int flag=0;
        
    while(scanf("%d",&n),n!=0)
    {
        memset(store, 0, sizeof store);//清零操作
        memset(count, 0, sizeof count);
        for(i=0;i<n;i++)//i只负责计数
    {
                scanf("%s",t);
                for(j=0;j<n;j++)//j从0开始,可以保证用count将所有重复的字符串进行计数
        {
                        flag=0;//标记是否重复
                        if(strcmp(t,store[j])==0)//与原有字符串进行比较
            {
                                    count[j]+=1;//如果原来存在,给相应地方加一
                                    flag=1;
                                    break;
                                
            }
                    
        }
                if(flag==0)//如果没有录入,进行录入
                    strcpy(store[i],t);
            
    }
        max=0;
            for(j=0;j<n;j++)//选出值最大下标
    {
                    if(count[max]<count[j])
                        max=j;
                
    }
            printf("%s\n",store[max]);
        scanf("%d",&n);
    }
            return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值