畅通工程
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 33666 Accepted Submission(s): 14892
Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。
Output
对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。
Sample Input
3 3 1 2 1 1 3 2 2 3 4 1 3 2 3 2 0 100
Sample Output
3 ?
并查集 + kursal,最后通过已路径个数判断合理性
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
const int MAXN = 100005 + 5;
int parent[MAXN];
struct Path{
int u;
int v;
int cost;
}paths[MAXN];
void initSet(){
for(int i = 0; i < MAXN; i ++)
parent[i] = i;
}
int find(int x){
return x == parent[x] ? x :
parent[x] = find(parent[x]);
}
bool unionSet(int a,int b){
int x = find(a);
int y = find(b);
if(x != y){
parent[x] = y;
return true;
}
return false;
}
bool cmp(const Path& a,const Path& b){
return b.cost > a.cost;
}
int main(){
int village,road;
while(scanf("%d%d",&road,&village) != EOF && road){
initSet();
for(int i = 0; i < road; i ++){
scanf("%d%d%d",&paths[i].u,
&paths[i].v,
&paths[i].cost);
}
sort(paths,paths+road,cmp);
int allCost = 0;
int cnt = 0;
for(int i = 0; i < road && cnt != village - 1; i ++){
int u = paths[i].u;
int v = paths[i].v;
if(find(u) != find(v)){
allCost += paths[i].cost;
cnt ++;
unionSet(u,v);
}
}
if(cnt != village - 1){
cout <<"?"<<endl;
}else{
cout <<allCost<<endl;
}
}
return 0;
}