HDU - 6029-Graph Theory-思维

Graph Theory

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1372    Accepted Submission(s): 602


Problem Description
Little Q loves playing with different kinds of graphs very much. One day he thought about an interesting category of graphs called ``Cool Graph'', which are generated in the following way:
Let the set of vertices be {1, 2, 3, ...,  n}. You have to consider every vertice from left to right (i.e. from vertice 2 to  n). At vertice  i, you must make one of the following two decisions:
(1) Add edges between this vertex and all the previous vertices (i.e. from vertex 1 to  i1).
(2) Not add any edge between this vertex and any of the previous vertices.
In the mathematical discipline of graph theory, a matching in a graph is a set of edges without common vertices. A perfect matching is a matching that each vertice is covered by an edge in the set.
Now Little Q is interested in checking whether a ''Cool Graph'' has perfect matching. Please write a program to help him.
 

Input
The first line of the input contains an integer  T(1T50), denoting the number of test cases.
In each test case, there is an integer  n(2n100000) in the first line, denoting the number of vertices of the graph.
The following line contains  n1 integers  a2,a3,...,an(1ai2), denoting the decision on each vertice.
 

Output
For each test case, output a string in the first line. If the graph has perfect matching, output ''Yes'', otherwise output ''No''.
 

Sample Input
 
 
3 2 1 2 2 4 1 1 2
 

Sample Output
 
 
Yes No

No

题意:

所以说 a set of 的意思是 一组...
只需找到的是一组边使得满足perfect matching!

题意:有n个点让你进行操作,从第二点开始,你可以开始操作,并且只能操作其中的任意一个,输入给出了点数和各点的操作,现在要求的就是是否有一组边满足perfect matching;perfect matching 的意思就是任何一个点当且仅当被一条边所覆盖;
两种操作分别是,1:当前点和所有前面的点都要连;2:当前点与前面任意点都不去相连!
思路:完美匹配就是: 。——。 。——。...... 这种方式;所以点数必须为偶数个。第一个点没有操作,可以假设它的操作为2,然后后面遇到一个1就和前面的2匹配一下,作何如果都匹配成功,就ok啦!
代码:
#include<bits/stdc++.h>
using namespace std;
const int maxn = 2e5+10;
int arr[maxn];
int main()
{
    int caset;scanf("%d",&caset);
    while(caset--)
    {
        int n;scanf("%d",&n);
        int cnt = 1;
        for(int i=2;i<=n;i++) scanf("%d",&arr[i]);
        if(n & 1) {
            printf("No\n");
            continue;
        }
        for(int i=2,x;i<=n;i++) {
            x = arr[i];
            if(x == 1 && cnt) cnt--;
            else cnt++;
        }
        if(cnt != 0) printf("No\n");
        else printf("Yes\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值