HDU - 6030-Happy Necklace-递推+矩阵快速幂

Happy Necklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1271    Accepted Submission(s): 541


Problem Description
Little Q wants to buy a necklace for his girlfriend. Necklaces are single strings composed of multiple red and blue beads.
Little Q desperately wants to impress his girlfriend, he knows that she will like the necklace only if for every prime length continuous subsequence in the necklace, the number of red beads is not less than the number of blue beads.
Now Little Q wants to buy a necklace with exactly  n beads. He wants to know the number of different necklaces that can make his girlfriend happy. Please write a program to help Little Q. Since the answer may be very large, please print the answer modulo  109+7.
Note: The necklace is a single string,  {not a circle}.
 

Input
The first line of the input contains an integer  T(1T10000), denoting the number of test cases.
For each test case, there is a single line containing an integer  n(2n1018), denoting the number of beads on the necklace.
 

Output
For each test case, print a single line containing a single integer, denoting the answer modulo  109+7.
 

Sample Input
 
 
223
 

Sample Output
 
 
3

4

题解:

对于 n = 2,我们有 rr,rb,br 3种

n = 3时,如果我们放r则直接放即可 f(n-1)

如果放b则必须要求前两个为rr 于是f(n-3)

综上 f(n) = f(n-1) + f(n-3)

根据这个递推公式我们去构造矩阵


f(0) = 1;f(1) = 2;f(2) = 3;f(3) = 4;f(4) = 6;

综上我们可以对矩阵进行快速幂进而得到f(n)


代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 4;
const ll mod = 1e9+7;
struct Matrix
{
    ll maze[maxn][maxn];
    int len;
    Matrix(){
        memset(maze,0,sizeof(maze));
        len = 0;
    }
    Matrix(int lens):len(lens){
        memset(maze,0,sizeof(maze));
    }
    void einit() {
        for(int i=0;i<len;i++)
            maze[i][i] = 1;
    }
    void Creat(int lens)
    {
        len = lens;
        if(len > maxn) exit(1);
        for(int i=0;i<len;i++)
            for(int j=0;j<len;j++)
            scanf("%lld",&maze[i][j]);
    }
    void output()
    {
        for(int i=0;i<len;i++)
        {
            for(int j=0;j<len-1;j++)
                printf("%lld ",maze[i][j]);
            printf("%lld\n",maze[i][len-1]);
        }
    }
    Matrix operator * (const Matrix &a){
        Matrix ans(len);
        for(int k=0;k<len;k++)
        {
            for(int i=0;i<len;i++) if(maze[i][k])
            {
                ll temp;
                for(int j=0;j<len;j++) if(a.maze[k][j])
                {
                    temp = (maze[i][k]*a.maze[k][j]) % mod;
                    ans.maze[i][j] = (ans.maze[i][j] + temp) % mod;
                }
            }
        }
        return ans;
    }
    Matrix power(ll b) {
        Matrix ans(len),a = (*this);ans.einit();
        while(b) {
            if(b & 1) ans = ans * a;
            a = a * a;
            b >>= 1;
        }
        return ans;
    }
    void operator = (const Matrix &a){
        len = a.len;
        for(int i=0;i<len;i++)
            for(int j=0;j<len;j++)
            maze[i][j] = a.maze[i][j];
    }
};
Matrix pows(3),now(3);
ll solve(ll n) {
    if(n == 2) return 3;
    if(n == 3) return 4;
    //printf("%lld\n",n);
    Matrix ans = now * pows.power(n-4);
    //ans.output();
    return ans.maze[2][2];
}
int main()
{
    pows.maze[0][2] = pows.maze[1][0] = pows.maze[2][1] = pows.maze[2][2] = 1;
    now.maze[0][0] = 1;now.maze[0][1] = 2;now.maze[0][2] = 3;
    now.maze[1][0] = 2;now.maze[1][1] = 3;now.maze[1][2] = 4;
    now.maze[2][0] = 3;now.maze[2][1] = 4;now.maze[2][2] = 6;
    int caset;scanf("%d",&caset);
    while(caset--) {
        ll n;scanf("%lld",&n);
        printf("%lld\n",solve(n));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值