山东省第六届ACM省赛 J Single Round Math

Single Round Math

Time Limit: 1000 ms  Memory Limit: 65536 KiB
Problem Description

Association for Couples Math (ACM) is a non-profit organization which is engaged in helping single people to find his/her other half. As November 11th is “Single Day”, on this day, ACM invites a large group of singles to the party. People round together, chatting with others, and matching partners.

There are N gentlemen and M ladies in the party, each gentleman should only match with a lady and vice versa. To memorize the Singles Day, ACM decides to divides to divide people into 11 groups, each group should have the same amount of couples and no people are left without the groups.

Can ACM achieve the goal?

Input

The first line of the input is a positive integer T. T is the number of test cases followed. Each test case contains two integer N and M (0 ≤ N, M ≤ 10^1000), which are the amount of gentlemen and ladies.

Output

For each test case, output “YES” if it is possible to find a way, output “NO” if not.

Sample Input
3
1 1
11 11
22 11
Sample Output
NO
YES
NO
Hint
Source

“浪潮杯”山东省第六届ACM大学生程序设计竞赛

题解:

判断是否被11整除。根据11的倍数的特征    奇数位数字之和与偶数位数字之和的差是11的倍数

或者通过高精度取余计算 

代码:

/**
    11的倍数的特征
*/
#include<bits/stdc++.h>
using namespace std;
string a,b;
int main()
{
    int caset;scanf("%d",&caset);
    while(caset--) {
        cin>>a>>b;
        if(a == b) {
            int ji = 0,ou = 0;
            for(int i=0;i<a.length();i++) {
                if(i & 1) ji += a[i] - 48;
                else ou += a[i] - 48;
            }
            if(abs(ji-ou) % 11 == 0) printf("YES\n");
            else printf("NO\n");
        }
        else printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值