【POJ1463】Strategic game

12 篇文章 0 订阅

                                                   Strategic game

Time Limit: 2000MS Memory Limit: 10000K
Total Submissions: 9456 Accepted: 4451

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree: 


the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description: 


  • the number of nodes 
  • the description of each node in the following format 
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads 
    or 
    node_identifier:(0) 


The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

 

解析:

       树形DP。

       令f[i][0/1]表示以i为根的子树选或不选i的最优解。

       如果不选ii的所有儿子都要选,否则不是不选而是可选可不选!

 

代码:
 

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cctype>
#include <cmath>
using namespace std;

const int Max=1505;
int n,m,size,x,y,sum;
int first[Max],f[Max][2];
struct shu{int to,next;};
shu edge[Max<<1];

inline int get_int()
{
	int x=0,f=1;
	char c;
	for(c=getchar();(!isdigit(c))&&(c!='-');c=getchar());
	if(c=='-') f=-1,c=getchar();
	for(;isdigit(c);c=getchar()) x=(x<<3)+(x<<1)+c-'0';
	return x*f;
}

inline void build(int x,int y)
{
	edge[++size].next=first[x];
	first[x]=size;
	edge[size].to=y;
}

inline void dfs(int point,int fa)
{
	f[point][1]=1;
	for(int u=first[point];u;u=edge[u].next)
	{
	  int to=edge[u].to;
	  if(to==fa) continue;
	  dfs(to,point);
	  f[point][0]+=f[to][1];
	  f[point][1]+=min(f[to][0],f[to][1]);
	}
}

inline void print(int x)
{
	if(x>9) print(x/10);
	putchar('0'+x%10);
}

int main()
{
	while(~scanf("%d",&n))
	{
	  size=0,memset(first,0,sizeof(first)),memset(f,0,sizeof(f));
  	  for(int i=1;i<=n;i++)
	  {
	    x=get_int()+1,sum=get_int();
	    for(int j=1;j<=sum;j++) y=get_int()+1,build(x,y),build(y,x);
	  }
	  dfs(1,0);
	  print(min(f[1][0],f[1][1])),putchar('\n');
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值