最小生成树 poj 2377 Bad Cowtractors

Bessie has been hired to build a cheap internet network among Farmer John’s N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn’t even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a “tree”.
Input
* Line 1: Two space-separated integers: N and M

  • Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.
    Output
  • Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.
    Sample Input
    5 8
    1 2 3
    1 3 7
    2 3 10
    2 4 4
    2 5 8
    3 4 6
    3 5 2
    4 5 17
    Sample Output
    42
    Hint
    OUTPUT DETAILS:

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

**Kuskal算法~~并查集真的很好用
另外建图时不要与最短路的各种vector建图法混淆。求最小生成树时,关注边数以及根据边权排的序,因此在结构体里简单定义并重载排序方式即可,这样一次循环即可找出构成树所需要的边。另外若在建树后还有不连通的两个点,则无法成树,输出-1~
一次就ac真的很美妙~**

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstring>
#include<queue>
#include<iostream>
//#include<random>
#include<functional>
#include<list>
#include<cstdlib>
#include<stdlib.h>
#include<vector>
#define lld long long int
#define INF 0x7fffffff
using namespace std;

struct edge
{
    int u,v,cost;
    //edge(int _u,int _v,int _c):u(_u), v(_v),cost(_c){}
}es[20050];

bool comp(edge a, edge b)
{
    return a.cost > b.cost;
}

//vector<edge>G[1050];
int n, m;
int parent[1050];
int height[1050];

void init()
{
    for (int i = 0;i < n;i++)
    {
        parent[i] = i;
        height[i] = 0;
    }
}

int find(int x)
{
    if (parent[x] == x) return x;
    else return parent[x] = find(parent[x]);
}

void unite(int a, int b)
{
    int x = find(a);
    int y = find(b);
    if (height[x] > height[y])
    {
        parent[y] = x;
    }
    else
    {
        parent[x] = y;
        if (height[x] == height[y])
            height[y]++;
    }
}

bool same(int x, int y)
{
    int a = find(x);
    int b = find(y);
    if (a == b) return 1;
    else return 0;
}

int main()
{
    while (~scanf("%d%d",&n,&m))
    {
        for (int i = 0;i < m;i++)
        {
            int a, b, c;
            scanf("%d%d%d", &a, &b, &c);
            a--;b--;
            es[i].u = a;
            es[i].v = b;
            es[i].cost = c;
            //G[a].push_back(edge(b ,c));
            //G[b].push_back(edge(a, c));
        }
        init();
        sort(es, es + m, comp);
        int ans = 0;
        for (int i = 0;i < m;i++)
        {
            if (!same(es[i].u, es[i].v))
            {
                unite(es[i].u, es[i].v);
                ans += es[i].cost;
            }
        }
        int flag = 0;
        for (int i = 0;i < n;i++)
        {
            for (int j = 0;j < n;j++)
            {
                if (!same(i, j))
                {
                    flag = 1;break;
                }
            }
            if (flag)break;
        }
        if (flag) printf("-1\n");
        else printf("%d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值