寒假集训_专题一题解_C(POJ - 1979)

题目

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input

6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0
Sample Output

45
59
6
13

题目大意

有一个人在走一个迷宫,他每次只能走上下左右中的一个方位,有一些障碍不能走,求其最多能走的位置个数。

分析

模板题,用bfs即可

代码

#include <iostream>
#include <queue>
using namespace std;
char op[100];
bool st[100][100];
int dx[4] = {0,0,1,-1},dy[4] = {-1,1,0,0};
int main()
{
	int m,n,x,y;
	while(scanf("%d%d",&m,&n) && m && n)
	{
		int cnt = 0;
		for(int i = 0; i < n; i ++)
		{
			scanf("%s",op);
			for(int j = 0; j < m; j ++)
				if(op[j] == '.')st[i][j] = true;
				else if(op[j] == '@')
				{
					x = i, y = j;
					st[i][j] = false; 
				}
				else st[i][j] = false;
		}
		pair<int,int> now[1000];
		now[1] = make_pair(x,y);
		int idx = 1;
		queue<int> q;
		q.push(1);cnt ++;
		while(!q.empty())
		{
			int t = q.front();
			q.pop();
			for(int i = 0; i < 4; i ++)
			{
				int tx = now[t].first + dx[i], ty = now[t].second + dy[i];
				if(tx >= 0 && tx < n && ty>=0 && ty < m && st[tx][ty])
				{
					st[tx][ty] = false;
					now[++idx] = make_pair(tx,ty);
					q.push(idx);
					cnt ++;
				}
			}
		}
		printf("%d\n",cnt);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值