题目
1734: [Usaco2005 feb]Aggressive cows 愤怒的牛
Description
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000). His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
农夫 John 建造了一座很长的畜栏,它包括NN (2 <= N <= 100,000)个隔间,这些小隔间依次编号为x1,…,xN (0 <= xi <= 1,000,000,000). 但是,John的C (2 <= C <= N)头牛们并不喜欢这种布局,而且几头牛放在一个隔间里,他们就要发生争斗。为了不让牛互相伤害。John决定自己给牛分配隔间,使任意两头牛之间的最小距离尽可能的大,那么,这个最大的最小距离是什么呢
Input
- Line 1: Two space-separated integers: N and C * Lines 2…N+1: Line i+1 contains an integer stall location, xi
第一行:空格分隔的两个整数N和C
第二行—第N+1行:i+1行指出了xi的位置
Output
- Line 1: One integer: the largest minimum distance
第一行:一个整数,最大的最小值
Sample Input
5 3
1
2
8
4
9
Sample Output
3
把牛放在1,4,8这样最小距离是3
题目大意
有N个盒子,他们再坐标位置为x1,…,xN (0 <= xi <= 1,000,000,000),有c头牛,需要放入这N个盒子中,求任意两头牛中最小距离的最大值
题解
若答案为ans,那么ans-k(k>=0)也一定满足题意,只需二分答案即可
代码
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
const int N = 1e5 + 10;
int a[N],n,c;
bool check(int x)
{
int t = c, l = -1e9 - 10;
for(int i = 1; i <= n && t; i ++)
{
if(n-i+1 < t)return false;
if(a[i] - l >= x)
{
l = a[i];
t--;
}
}
return t == 0;
}
int main()
{
cin >> n >> c;
for(int i = 1; i <= n; i ++)
scanf("%d", &a[i]);
sort(a+1,a+1+n);
int l = 0, r = 1e9, mid;
while(l < r)
{
mid = (l + r + 1)/2;
if(check(mid))l = mid;
else r = mid-1;
}
printf("%d\n",l);
return 0;
}
注意点
1.二分注意死循环