寒假集训_专题四题解_I - Saving Beans (HDU - 3037)

题目

Although winter is far away, squirrels have to work day and night to save beans. They need plenty of food to get through those long cold days. After some time the squirrel family thinks that they have to solve a problem. They suppose that they will save beans in n different trees. However, since the food is not sufficient nowadays, they will get no more than m beans. They want to know that how many ways there are to save no more than m beans (they are the same) in n trees.

Now they turn to you for help, you should give them the answer. The result may be extremely huge; you should output the result modulo p, because squirrels can’t recognize large numbers.
Input
The first line contains one integer T, means the number of cases.

Then followed T lines, each line contains three integers n, m, p, means that squirrels will save no more than m same beans in n different trees, 1 <= n, m <= 1000000000, 1 < p < 100000 and p is guaranteed to be a prime.
Output
You should output the answer modulo p.
Sample Input
2
1 2 5
2 1 5
Sample Output
3
3

Hint
Hint

For sample 1, squirrels will put no more than 2 beans in one tree. Since trees are different, we can label them as 1, 2 … and so on.
The 3 ways are: put no beans, put 1 bean in tree 1 and put 2 beans in tree 1. For sample 2, the 3 ways are:
put no beans, put 1 bean in tree 1 and put 1 bean in tree 2.

题目大意

求把不超过m颗豆子放入n棵树的方案数。(树中可以不放入豆子)

题目解析

先求把m颗豆子放入n棵树的方案数。运用隔板法可求出答案为C(m+n-1,n-1)。所以最终答案只需把m从0~m求和即可。即ans = C(n-1,n-1)+C(n,n-1)+C(n+1,n-1)+……+C(m+n-1,n-1) = C(n,n)+C(n,n-1)+C(n+1,n-1)+……+C(m+n-1,n-1),再通过公式C(m,n)=C(m-1,n)+C(m-1,n-1)可知ans=C(m+n,n),再通过Lucas定理求得答案

代码

#include <iostream>
using namespace std;
typedef long long LL; 
const int N = 1e5+10;
LL m,n,p,f[N],inf[N];
LL qmi(LL a, LL b)
{
   LL res = 1%p, t = a % p;
   while(b)
   {
   	if(b&1)res = res * t % p;
   	t = t*t%p;
   	b >>=1;
   }
   return res;
}
LL C(LL a, LL b)
{
   if(a==b)return 1;
   if(a<b)return 0;
   return f[a]*qmi(f[b]*f[a-b]%p,p-2)%p;
}
LL Lucas(LL a, LL b)
{
   if(b==0)return 1;
   if(a>=p||b>=p)return Lucas(a/p,b/p)*C(a%p,b%p)%p;
   else return C(a,b);
}

int main()
{
   f[0] = inf[0] = 1;
   int T;cin>>T;
   while(T--)
   {
   	scanf("%lld%lld%lld",&n,&m,&p);
   	for(int i = 1; i <= p; i ++)
   	{
   		f[i] = i*f[i-1]%p;
   		//inf[i] = inf[i-1]*qmi(i,p-2);//会TLE 
   	}
   	LL ans = Lucas(m+n,n);
   	cout << ans%p << endl;
   }
   return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值