POJ 2406 Power Strings——字符串哈希

传送门

Description
Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

题意: 判断字符串最多由多少个子串重复而组成。

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
typedef unsigned long long ull;

int ans, sum, len;
char s[1000005];
ull has[1000005];
int main(){
    while(~scanf("%s", s+1) && s[1]!='.'){
        sum = ans = 1;
        len = strlen(s+1);
        for (int i = 1; i <= len; i++)
            has[i] = has[i-1] * 131 + s[i] - 'a';
            
        ull tem = 1;
        for (int l = 1; l <= len; l++){
            tem *= 131;
            if(len % l)    continue;
            int p = sum = 1;
            while (p+l <= len){
                ull a = has[p + l - 1] - has[p - 1] * tem;
                ull b = has[p + 2 * l - 1] - has[p + l - 1] * tem;
                if(a != b){
                    sum = 1;
                    break;
                }
                sum++;
                p += l;
            }
            if(ans < sum){
                ans = sum;
                break;
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值