PAT(A1021 A1089) 详解

 

 

固定套路

固定套路
typedef long long ll;
struct Fraction{
    ll up, down;
};
ll gcd(ll a, llb){
    return b==0?a:gcd(b,a%b);//若用gcd(b, a)会运行超时
}
//化简函数
Fraction reduction(Fraction result){//化简函数
    if(result.down < 0){
        result.down = -result.down;
        result.up = -result.up;
    }
    if(result.up == 0) result.down =1;
    else if(result.up != 0){
        int d = gcd(abs(result.up), abs(result.down));
        result.up /= d;
        result.down /= d;
    }
    return result;
}
//输出函数
void showResult(Fraction result){
    reduction(result);
    if(result.down == 1)  printf("%lld\n", result.up);
    else if(abs(result.up) > result.down) printf("%lld %lld/%lld\n", result.up/result.down, abs(result.up)%result.down, result.down);
    else printf("%lld/%lld\n", result.up, result.down);
}

//分数的加法
    Fraction add(Fraction f1, Fraction f2){//分数相加函数
    Fraction result;
    result.up = f1.up*f2.down + f2.up*f1.down;
    result.down = f1.down*f2.down;
    return reduction(result);
}
//分数减法
Fraction minu(Fraction f1,Fraction f2){
    Fraction result;
    result.up = f1.up * f2.down - f2.up*f1.down;
    result.down = f1.down*f2.down;
    return reduction(result);
}
//分数乘法
Fraction multi(Fraction f1, Fraction f2){
    Fraction result;
    result.up = f1.up*f2.up;
    result.down = f1.down*f2.down;
    return reduction(result);
}

//分数除法
Fraction divide(Fraction f1, Fraction f2){
    Fraction result;
    result.up = f1.up*f2.down;
    result.down = f1.down*f2.up;
    return reduction(result);
}

1081 Rational Sum (20分)

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8
7/24

Sample Output 3:

 

#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long ll;

ll gcd(ll a, ll b){
    return b == 0 ? a:gcd(b, a%b);
	}
struct Fraction{
    ll up, down;
};

Fraction reduction(Fraction result){//化简函数
    if(result.down < 0){
        result.down = -result.down;
        result.up = -result.up;
    }
    if(result.up == 0) result.down =1;
    else if(result.up != 0){
        int d = gcd(abs(result.up), abs(result.down));
        result.up /= d;
        result.down /= d;
    }
    return result;
}

Fraction add(Fraction f1, Fraction f2){//分数相加函数
    Fraction result;
    result.up = f1.up*f2.down + f2.up*f1.down;
    result.down = f1.down*f2.down;
    return reduction(result);
}

void showResult(Fraction r){//输出分数
    reduction(r);
    if(r.down == 1)  printf("%lld\n", r.up);
    else if(abs(r.up) > r.down) 
    printf("%lld %lld/%lld\n", r.up/r.down, abs(r.up)%r.down, r.down);
    else printf("%lld/%lld\n", r.up, r.down);
}
int main(){
    int n;
    scanf("%d", &n);
    Fraction sum, temp;//
    sum.up = 0; sum.down = 1;
    for(int i = 0; i < n; i++){
        scanf("%lld/%lld", &temp.up,&temp.down);
        sum = add(sum, temp);//在sum上加temp
    }
    showResult(sum);
    return 0;

}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值